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NAPOLEON ELECTRIC FIREPLACES
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Revised: February 2024  •  Replaces: May 2023

BUILT-IN ELECTRIC FIREPLACES

STEP 1 – ASTOUND™ LINEAR BUILT-IN PREMIUM FIREPLACE MODELS (Mandatory. Choose base unit)
Product Description NEFB50AB NEFB62AB NEFB74AB NEFB96AB
Astound Built-in Electric Fireplace Price: P.O.A. P.O.A. P.O.A. P.O.A.

Part ID: NEFB50AB NEFB62AB NEFB74AB NEFB96AB
Item #: C673600 C673600 C673600 C673600

STEP 2 – OPTIONAL MEDIA
Product Description NEFB50AB NEFB62AB NEFB74AB NEFB96AB
Birch Logs Price: P.O.A. P.O.A. P.O.A. P.O.A.

Part ID: BLKM BLKL BLKXL BLKXL
Item #: 672267 672259 C673600 C673600

Mineral Rock Kit Price: P.O.A. P.O.A. P.O.A. P.O.A.
Part ID: MRKM MRKL MRKXL MRKXL
Item #: 672274 C673600 C673600 C673600

Glass Beads Media Kits Price:
Recommended: 2 Kits for 50/62, 3 Kits for 74/96 Part ID &

Item #:
Black Crystals (Must order quantities of each part Price: P.O.A. P.O.A. P.O.A. P.O.A.
indicated in brackets) Part ID: (3) G497-0004 (2) G497-0004 (3) G497-0005 (5) G497-0004

(2) G497-0006 (1) G497-0005 (3) G497-0006 (3) G497-0007
(2) G497-0007

STEP 3 – ADDITIONAL PARTS AND ACCESSORIES (OPTIONAL)
Product Description NEFB50AB NEFB62AB NEFB74AB NEFB96AB
Wall Mount Controller (incl. wire, white and black Price:
glass fronts) Part ID:

Item #:
W370-0317
C673600

Astound Series

C673600: MKBA (Amber); MKBK (Black); MKBB (Blue)
P.O.A.

673259: MKBC (Clear)  672269: MKBT (Topaz)

P.O.A.

FEATURES
> Up to 10,000 BTU's and 3,000 Watts > Frameless finishing flange or adjustable trim both included
> 2 Year Registered Warranty in the box
> Can be Hardwired – 120V or 240V > Orange, yellow and combined flame colors
> See Through Patented Technology > Premium remote included with Napoleon Home App
> Extra large viewing area to enjoy flames featuring realistic compatibility

spark effect > Wall mount controller optional with black or white front
> Unique flip-down glass design for easy media changes > Voice control capabilities (Google Home, Alexa)
> Beach Fire logs & Woodland media kit included

NEFB62AB NEFB74AB NEFB96ABNEFB50AB
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NAPOLEON ELECTRIC FIREPLACES
www.napoleonfireplaces.com

Revised: February 2024  •  Replaces: May 2023

BUILT-IN ELECTRIC FIREPLACES

STEP 1 – CLEARION™ ELITE ELECTRIC FIREPLACE MODELS (Mandatory. Choose base unit)
Product Description NEFBD50HE NEFBD60HE
CLEARion™ Elite Built-in Electric Fireplace Price: P.O.A. P.O.A.

Part ID: NEFBD50HE NEFBD60HE
Item #: 673185 673180
Pkg. Wt: 131.2 lbs. 176.4 lbs.

STEP 2 – MEDIA KITS AND GLASS KITS (Optional)
Product Description NEFBD50HE NEFBD60HE
Surrounds to Accommodate 2" × 4" Wall Installation, Black (for Both Sides) Price: P.O.A. P.O.A.

Part ID: NEFBD50HE-DTRM NEFBD60HE-DTRM
Item #: C673600 C673600

Surrounds to Accommodate 2" × 4" Wall Installation, Stainless Steel (for Both Sides) Price: P.O.A. P.O.A.
Part ID: NEFBD50HE-SS-DTRM NEFBD60HE-SS-DTRM
Item #: C673600 C673600

Stainless Steel Surrounds to Accommodate 2" × 8" Wall Installation (for Both Sides) Price: P.O.A.
Part ID: NEFBD50HE-SS-TRIM
Item #: C673600

Amber Glass Embers Media Kit Price: P.O.A. P.O.A.
Part ID: MKGA MKGA
Item #: 674171 674171

Black Glass Embers Media Kit Price: P.O.A. P.O.A.
Part ID: MKGK MKGK
Item #: 674169 674169

N/A

CLEARion™ Elite Series

Continued on next page

FEATURES
> Up to 10,000 BTU's and 3,000 Watts > Can be Hardwired – 120V or 240V
> Privacy Glass Feature > Multi-Color Ember Bed
> 2 Year Warranty > Simple Framing Specifications
> See Through Patented Technology > Heaters Operate Independently from Each Side
> Log Set with Topaz Glass and Crystal Media Included > Full Feature Remote Control
> Flame/Heat Adjustment

CLEARion Elite 50 Glass in see through mode CLEARion Elite 50 Glass in semi-transparent mode CLEARion Elite 50 Glass in opaque mode

BUILT-IN ELECTRIC FIREPLACES

STEP 2 – MEDIA KITS AND GLASS KITS (Mandatory. Choose one to complete unit) Continued
NEFBD50HE NEFBD60HE

Blue Glass Embers Media Kit Price: P.O.A. P.O.A.
Part ID: MKGB MKGB
Item #: 674167 674167

Clear Glass Embers Media Kit Price: P.O.A. P.O.A.
Part ID: MKGC MKGC
Item #: 674173 674173

Red Glass Embers Media Kit Price: P.O.A. P.O.A.
Part ID: MKGR MKGR
Item #: 674168 674168

CLEARion™ Elite Series Continued
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NAPOLEON ELECTRIC FIREPLACES
www.napoleonfireplaces.com

Revised: February 2024  •  Replaces: May 2023

BUILT-IN ELECTRIC FIREPLACES

STEP 1 – TRIVISTA™ PRIMIS ELECTRIC FIREPLACE MODELS (Mandatory. Choose base unit)
Product Description NEFB50H-3SV NEFB60H-3SV
Trivista™ Primis Built-in Electric Fireplace Price: P.O.A. P.O.A.

Part ID: NEFB50H-3SV NEFB60H-3SV
Item #: 673203 673208
Pkg. Wt: 113 lbs. 131 lbs.

Trivista™ Primis Series

FEATURES
> Up to 10,000 BTU's and 3,000 Watts > Combination of Northern Woods Log Set and Crystal Media
> 2 Year Warranty > Multi-Color Ember Bed
> 1, 2 or 3 Sided View > Flame/Heat Adjustment
> Hardwire to 120V or 240V > Full Feature Remote Control

NEFB50H-3SV NEFB60H-3SV
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NAPOLEON ELECTRIC FIREPLACES
www.napoleonfireplaces.com

Revised: February 2024  •  Replaces: May 2023

BUILT-IN ELECTRIC FIREPLACES

STEP 1 – ELEMENT™ ELECTRIC FIREPLACE MODELS (Mandatory. Choose base unit)
Product Description NEFB36H-BS NEFB42H-BS
Element™ Built-in Electric Fireplace Price: P.O.A. P.O.A.

(previously NEFB36H-BS – 673186; NEFB42H-BS – 673209) Part ID: NEFB36H-BS-1 NEFB42H-BS-1
Item #: C673600 C673600
Pkg. Wt: 74.9 lbs. 106.83 lbs.

STEP 2 – ADDITIONAL PARTS AND ACCESSORIES (Optional)
Product Description NEFB36H-BS NEFB42H-BS
3/4 pc. Trim kit (5") Price: P.O.A. P.O.A.

Part ID: NEFB36H-BS-TRIM NEFB42H-BS-TRIM
Item #: C673600 C673600

Element™ Series

FEATURES
> Up to 10,000 BTU's > Plug-In or Hardwire 120V/240V
> Up to 3,000 Watts > Multi-Function Remote Included
> 2 Year Limited Warranty > Thermostatic Function
> Vivid Flame Effect > Top Light in 7 Color Settings
> Self-Trimming > 7pc Oak Log Set Included (NEFB42H-BS only)

NEFB36H-BS NEFB42H-BS
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NAPOLEON ELECTRIC FIREPLACES
www.napoleonfireplaces.com

Revised: February 2024  •  Replaces: May 2023

BUILT-IN ELECTRIC FIREPLACES

STEP 1 – CINEVIEW™ ELECTRIC FIREPLACE MODELS (Mandatory. Choose base unit)
Product Description NEFB26H NEFB30H
Cineview™ Built-in Electric Fireplace Price: P.O.A. P.O.A.

Part ID: NEFB26H NEFB30H
Item #: 673199 673165
Pkg. Wt: 46.3 lbs. 51.4 lbs.

STEP 2 – ADDITIONAL PARTS AND ACCESSORIES (Optional)
Product Description NEFB26H NEFB30H
Optional 3/4pc Trim Kit Price: P.O.A. P.O.A.

Part ID: NEFTK2636 NEFTK3040
Item #: C673600 673079

Zero Clearance 3/4 pc trim kit for 36" Wood Box Price: P.O.A. P.O.A.
Part ID: NEFTK30BK-3828 NEFTK30BK-4432
Item #: C673600 C673600

Cineview™ Series

FEATURES
> 5,000 BTU's > ECO Mode: Heater at Half Heat
> 1 Year Warranty > Boost Mode: Heater at Max Heat with Accelerated Fan Speed
> 1,500 Watts > 7 Ember Bed Color Options
> Plug-In or Hardwire > Orange, Blue and Multi-Color Flame Options
> Logs and Black Crystal Media > Touch Screen Control Panel

NEFB26H NEFB30H
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NAPOLEON ELECTRIC FIREPLACES
www.napoleonfireplaces.com

Revised: February 2024  •  Replaces: May 2023

BUILT-IN ELECTRIC FIREPLACES

STEP 1 – ASCENT™ ELECTRIC FIREPLACE MODELS (Mandatory. Choose base unit)
Product Description NEFB33H NEFB40H
Ascent™ Built-in Electric Fireplace Price: P.O.A. P.O.A.

Part ID: NEFB33H NEFB40H
Item #: 673162 673163
Pkg. Wt: 74.0 lbs. 101 lbs.

Ascent™ Electric Series

FEATURES
> Up to 9,000 BTU's > WHISPER QUIET™ Fan and Heater
> 2 Year Warranty > NIGHT LIGHT™
> 2,650 Watts > Realistic Brick Panels, Log Set and Glowing Embers
> Plug-in or Hardwire to 120V/240V > Self-Trimming Flange
> Ultra Bright LED Lights

NEFB33H NEFB40H
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Revised: February 2024  •  Replaces: May 2023

WALL HANGING ELECTRIC FIREPLACES

STEP 1 – STYLUS™ ELECTRIC FIREPLACE MODELS (Mandatory. Choose base unit)
Product Description
Stylus™ Cara Elite Electric Fireplace Price: P.O.A.

Part ID: NEFP32-5019W-IOT
Item #: C673600
Pkg. Wt: 98.5 lbs.

Stylus™ Cara Electric Fireplace Price: P.O.A.
Part ID: NEFP32-5019W
Item #: 673198
Pkg. Wt: 95 lbs.

Stylus™ Steinfeld Electric Fireplace Price: P.O.A.
Part ID: NEFP32-5320BW
Item #: C673600
Pkg. Wt: 92 lbs.

Stylus™ Series

FEATURES
> Up to 5,000 BTU's > Seven Ember Bed Color Settings
> 2 Year Warranty > 53" Wide Wood Surround (Steinfeld)
> Combination of Birch Log Set and Crystal Media > 59" Wide Wood Surround (Cara, Cara Elite)
> 1,500 Watts > Smart Technology Integration (Cara Elite)
> Remote Control Included > Weather & Information Display (Cara Elite)
> Dual USB Charger Ports > Auto-Off Timer (Cara Elite)
> Shelf with Accent Light > Voice Control Integration (Cara Elite)
> Seven Flame Color Settings

NEFP32-5019W-IOT – Cara Elite NEFP32-5320BW – SteinfeldNEFP32-5019W – Cara
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Revised: February 2024  •  Replaces: May 2023

WALL HANGING ELECTRIC FIREPLACES

STEP 1 – ALLURAVISION™ DEEP DEPTH ELECTRIC FIREPLACE MODELS (Mandatory. Choose base unit)
Product Description
Alluravision™ 42 Deep Depth Electric Fireplace Price: P.O.A.

Part ID: NEFL42CHD-1
(previously NEFL42CHD – 673204) Item #: C673600

Pkg. Wt: 63.3 lbs.
Alluravision™ 50 Deep Depth Electric Fireplace Price: P.O.A.

Part ID: NEFL50CHD-1
(previously NEFL50CHD – 673201) Item #: C673600

Pkg. Wt: 94.8 lbs.
Alluravision™ 60 Deep Depth Electric Fireplace Price: P.O.A.

Part ID: NEFL60CHD-1
(previously NEFL60CHD – 673202) Item #: C673600

Pkg. Wt: 86 lbs.
Alluravision™ 74 Deep Depth Electric Fireplace Price: P.O.A.

Part ID: NEFL74CHD-1
(previously NEFL74CHD – 673175) Item #: C673600

Pkg. Wt: 130 lbs.
Alluravision™ 100 Deep Depth Electric Fireplace Price: P.O.A.

Part ID: NEFL100CHD-1
Item #: C673600
Pkg. Wt: 167.6 lbs.

Alluravision™ Deep Series

FEATURES
> Up to 9,500 BTU's > Yellow, Orange, Blue or Combined Flame Color Options
> 2 Year Warranty > Can be Fully Recessed or Hung on the Wall
> Log Set and Crystal Clear Cube Ember Bed > LED Lighting
> WHISPER QUIET™ Blower with Boost Function > Touch Screen Control Panel
> Simply Plugs into 120V Outlet > Multi-Color Ember Bed and NIGHT LIGHT
> Can be Hardwired 120/240V > South Beach Log Set Included
> Deep View Design > Paintable Cord Cover

NEFL100CHD-1 – Deep

NEFL42CHD-1 – Deep NEFL50CHD-1 – Deep NEFL60CHD-1 – Deep NEFL74CHD-1 – Deep

PROMOTIONAL PRICING MAY BE AVAILABLE.
WHILE QUANTITIES LAST!
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NAPOLEON ELECTRIC FIREPLACES
www.napoleonfireplaces.com

Revised: February 2024  •  Replaces: May 2023

WALL HANGING ELECTRIC FIREPLACES

STEP 1 – ALLURAVISION™ SLIMLINE ELECTRIC FIREPLACE MODELS (Mandatory. Choose base unit)
Product Description
Alluravision™ 42 Slimline Electric Fireplace Price: P.O.A.

Part ID: NEFL42CHS-1
(previously NEFL42CHS – 673166) Item #: C673600

Pkg. Wt: 46.7 lbs.
Alluravision™ 50 Slimline Electric Fireplace Price: P.O.A.

Part ID: NEFL50CHS-1
(previously NEFL50CHS – 673167) Item #: C673600

Pkg. Wt: 73 lbs.
Alluravision™ 60 Slimline Electric Fireplace Price: P.O.A.

Part ID: NEFL60CHS-1
(previously NEFL60CHS – 673184) Item #: C673600

Pkg. Wt: 84.2 lbs.
Alluravision™ 74 Slimline Electric Fireplace Price: P.O.A.

Part ID: NEFL74CHS-1
(previously NEFL74CHS – 673173) Item #: C673600

Pkg. Wt: 104 lbs.

Alluravision™ Slimline Series

FEATURES
> Up to 5,000 BTU's > Yellow, Orange, Blue or Combined Flame Color Options
> 2 Year Warranty > Can be Fully Recessed into the Wall or Easily Hung
> Crystal Clear Cube Ember Bed > LED Lighting
> WHISPER QUIET™ Blower with Boost Function > Touch Screen Control Panel
> Simply Plugs into 120V Outlet > Multi-Color Ember Bed and NIGHT LIGHT™
> Can be Hardwired 120V > Paintable Cord Cover
> Ultra Slim Design

NEFL42CHS-1 – Slim NEFL50CHS-1 – Slim NEFL60CHS-1 – Slim NEFL74CHS-1 – Slim

PROMOTIONAL PRICING MAY BE AVAILABLE.
WHILE QUANTITIES LAST!
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NAPOLEON ELECTRIC FIREPLACES
www.napoleonfireplaces.com

Revised: February 2024  •  Replaces: May 2023

WALL HANGING ELECTRIC FIREPLACES

STEP 1 – TRIVISTA™ PICTURA ELECTRIC FIREPLACE MODELS (Mandatory. Choose base unit)
Product Description NEF50H-3SV NEF60H-3SV
Trivista™ Pictura Built-in Electric Fireplace Price: P.O.A. P.O.A.

Part ID: NEFL50H-3SV NEFL60H-3SV
Item #: C673600 C673600
Pkg. Wt: 72.3 lbs. 85.1 lbs.

STEP 2 – ADDITIONAL PARTS AND ACCESSORIES (Optional)
Product Description NEF50H-3SV NEF60H-3SV
Birch log set with rocks Price: P.O.A. P.O.A.

Part ID: NEF-BLRAK50 NEF-BLRAK60
Item #: C673600 C673600

Driftwood log set with rocks Price: P.O.A. P.O.A.
Part ID: NEF-DRAK50 NEF-DRAK60
Item #: C673600 C673600

Trivista™ Pictura Series

FEATURES
> Up to 5,000 BTUs and 1,500 Watts > Multi-Color Ember Bed
> 1 Year Warranty > Smoky Side Glass
> Flame/Heat Adjustment > Full Feature Remote Control
> Mixture of Large and Small Crystal Media > Large Digital Display
> Multi-Color Flames

NEFL50H-3SV NEFL60H-3SV
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NAPOLEON ELECTRIC FIREPLACES
www.napoleonfireplaces.com

Revised: February 2024  •  Replaces: May 2023

WALL HANGING ELECTRIC FIREPLACES

STEP 1 – ENTICE™ ELECTRIC FIREPLACE MODELS (Mandatory. Choose base unit)
Product Description NEFL36CFH NEFL42CFH NEFL50CFH NEFL60CFH NEFL72CFH
Entice™ Electric Fireplace – Wall Mount Price: P.O.A. P.O.A. P.O.A. P.O.A. P.O.A.

(previously NEFL36CFH – 673188; NEFL42CFH-1 – 673205; Part ID: NEFL36CFH-1 NEFL42CFH-1 NEFL50CFH-1 NEFL60CFH-1 NEFL72CFH-1
NEFL50CFH-1 – 673206; NEFL60CFH – 6733187; Item #: C673600 C673600 C673600 C673600 C673600

NEFL72CFH – 673207) Pkg. Wt: 46.3 lbs. 50.25 lbs. 56.88 lbs. 76.06 lbs. 93.7 lbs.

STEP 2 – ADDITIONAL PARTS AND ACCESSORIES (Optional)
Product Description NEFL36CFH NEFL42CFH NEFL50CFH NEFL60CFH NEFL72CFH
Birch Log Set with Rocks Price: P.O.A. P.O.A. P.O.A. P.O.A. P.O.A.

Part ID: NEF-BLRAK42 NEF-BLRAK42 NEF-BLRAK50 NEF-BLRAK60 NEF-BLRAK72
Item #: C673600 C673600 C673600 C673600 C673600

Driftwood Log Set with Rocks Price: P.O.A. P.O.A. P.O.A. P.O.A. P.O.A.
Part ID: NEF-DRAK42 NEF-DRAK42 NEF-DRAK50 NEF-DRAK60 NEF-DRAK72
Item #: C673600 C673600 C673600 C673600 C673600

Entice™ Series

FEATURES
> Up to 5,000 BTU's > Remote Control Included
> 2 Year Warranty > Wall Mount, Partial and Fully Recessed Installations
> Simply Plugs into 120V Outlet > Touch Control Panel
> Can be Hardwired 120V > Pre-set Flame and Ember Bed Color Combinations
> 10 Flame and Ember Bed colors > Optional Log Sets Available

NEFL36CFH-1 NEFL42CFH-1 NEFL50CFH-1 NEFL60CFH-1 NEFL72CFH-1
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NAPOLEON ELECTRIC FIREPLACES
www.napoleonfireplaces.com

Revised: February 2024  •  Replaces: May 2023

WALL HANGING ELECTRIC FIREPLACES

STEP 1 – ALLURE™ VERTICAL ELECTRIC FIREPLACE MODELS (Mandatory. Choose base unit)
Product Description
Allure™ Vertical 32 Electric Fireplace Price: P.O.A.

Part ID: NEFVC32H
Item #: 673177
Pkg. Wt: 33 lbs.

Allure™ Vertical 38 Electric Fireplace Price: P.O.A.
Part ID: NEFVC38H
Item #: 673178
Pkg. Wt: 38.5 lbs.

Allure™ Vertical Series

FEATURES
> Up to 5,000 BTU's > LED Side Accent Lighting
> 1,500 Watts > Flame Speed Adjustment
> 1 Year Warranty > Multiple Ember Bed Color Options
> Simply Plugs into 120V Outlet > Multi-Function Remote Control
> Wall Mount or Partially Recessed > Can be Hardwired
> Ultra Slim Design > Paintable Cord Cover
> Blue, Orange, Yellow or Multi-Color Flames

NEFVC32H NEFVC38H



ECCO Supply™13-14  www.eccosupply.ca

– E.&O.E. – All Prices F.O.B. Our Warehouse – Subject to Change Without Notice – All Taxes Extra – May not be Available at All Branches –

NAPOLEON ELECTRIC FIREPLACES
www.napoleonfireplaces.com

Revised: February 2024  •  Replaces: May 2023

Essential Series

STEP 1 – ESSENTIAL SERIES MANTEL PACKAGES (Mandatory. Choose Base Unit)
Product Description
The Bella Electric Mantel Package Price: P.O.A.

Part ID: NEFP26-3120WN
Item #: C673600

The Hayworth Electric Mantel Package Price: P.O.A.
Part ID: NEFP30-3620RLB
Item #: C673600

Note: Essential Series Mantel Packages are shipped in two boxes.

BELLA FEATURES HAYWORTH FEATURES
> Walnut finish > Rustic Long Board finish
> Electronic media compartment with wire management system > Electronic media compartment with wire management system
> Soft closing doors with decorative metal handles and metal legs > Soft closing doors with decorative metal handles
> Rustic design > Rustic charm

ELECTRIC FIREPLACE / MANTEL PACKAGES
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NAPOLEON ELECTRIC FIREPLACES
www.napoleonfireplaces.com

Revised: February 2024  •  Replaces: May 2023

Essential Series (Continued)

STEP 1 – ESSENTIAL SERIES MANTEL PACKAGES (Mandatory. Choose Base Unit)
Product Description
The Charlotte Electric Mantel Package Price: P.O.A.

Part ID: NEFP30-3820AW
Item #: C673600

The Franklin Electric Mantel Package Price: P.O.A.
Part ID: NEFP30-3020RK
Item #: C673600

Note: Essential Series Mantel Packages are shipped in two boxes.

ELECTRIC FIREPLACE / MANTEL PACKAGES

CHARLOTTE FEATURES FRANKLIN FEATURES

> Mahogany finished top with Antique White finished body > Weathered oak finish and industrial metal accents
> Top and bottom molding with a whitewashed base > Electronic media compartment with wire management system
> Electronic media compartment with wire management system > Soft closing doors with decorative metal door handles
> Soft closing doors with decorative metal door knobs > Mid-Century modern
> Traditional Farmhouse design
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NAPOLEON ELECTRIC FIREPLACES
www.napoleonfireplaces.com

Revised: February 2024  •  Replaces: May 2023

ELECTRIC LOG SETS

WOODLAND™ ELECTRIC LOG SET MODELS (Mandatory. Choose base unit)
Product Description

Price: P.O.A.
Part ID: NEFI18H
Item #: 673200
Pkg. Wt: 27.5 lbs.
Price: P.O.A.
Part ID: NEFI24H
Item #: 672357
Pkg. Wt: 33 lbs.
Price: P.O.A.
Part ID: NEFI27H
Item #: 672358
Pkg. Wt: 35 lbs.

Woodland™ Series

Woodland™ 18 Electric Log Set

Woodland™ 24 Electric Log Set

Woodland™ 27 Electric Log Set

FEATURES
> Up to 5,000 BTU's > Safe to Touch
> 1 Year Limited Warranty > Can be Hardwired
> Hand Painted Resin Log Set > Projected Flame Effect
> High Intensity LED Lights > Remote Control Included
> Flame/Heat Adjustment

NEFI18H NEFI24H NEFI27H
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